Just a quick note worthy yay on internet security, Firefox 59.0.2 and up has TLS v1.3 supported.

PS: had compiled nginx with OpenSSL 1.1.1-pre5-dev from the Github with enable-tls1_3 compile flag to get it working on the server a couple weeks ago ;-)

AY.HX TLS v1.3